Which version of BizTalk is BizTalkCop compatible with?

Dec 12, 2008 at 11:15 AM
Is it for 2006 / 2006 R2 or only BizTalk 2009?
Coordinator
Dec 16, 2008 at 3:36 PM
It was built and tested against 2006 R2, though there's nothing in there that would stop it working for 2006 - or in theory 2009 as the runtime isn't massively different.

For 2009 though you have the option of running analysis from inside Visual Studio, so I'm looking at enhancing BizTalkCop so the rules can be loaded into VS for 2009 development, or used with standalone FxCop for 2006/R2 development.


Mar 28, 2014 at 12:51 PM
And it can be got working against BizTalk 2010 with a bit of tweaking ...

Original idea

My notes to remind me how to do it ...